Vue 2.5.1でbootstrap-vueのエラーが発生

Vue 2.5.1にアップデートしたら次のようなエラーが発生するようになりました。

Invalid value for option "components": expected an Object, but got Array.

原因はbootstrap-vueのようです。

対策は以下のプルリクの通り。
変更点をmain.jsなどのVueの起点に追記すればOKです。

https://github.com/kayentech/kayen-website/pull/2/files

本家の対応が済んだら元に戻すのを忘れないように。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です