GitlabのWikiをgollumで編集したときにエラーが出る

基本的な設定方法はwiki/git_accessに載っています。

GitlabでまだWikiを編集してない場合は上のチュートリアルで事足ります。

すでにWikiを編集してしまった場合、gollumで編集しようとすると、下記のようなエラーが発生します。

Encoding::CompatibilityError at /create
incompatible character encodings: UTF-8 and ASCII-8BIT

解決策はこちらにありました。

https://github.com/gollum/gollum/issues/843

結局、Macで動作確認をして採用を見送ったので、Macでの方法を書いておきます。

brew install cmake
gem install github-markdown
gem install gollum-rugged_adapter

あとはオプションをつけて起動するだけです。

gollum --adapter rugged